Principal Pc Y Mac ¿Los correos electrónicos distinguen entre mayúsculas y minúsculas?

¿Los correos electrónicos distinguen entre mayúsculas y minúsculas?



Existe mucha confusión sobre si las direcciones de correo electrónico distinguen entre mayúsculas y minúsculas o no. Algunos dicen que sí, mientras que otros afirman que no. Entonces, ¿quién tiene razón? En este artículo, analizaremos si las direcciones de correo electrónico distinguen entre mayúsculas y minúsculas.

¿Los correos electrónicos distinguen entre mayúsculas y minúsculas?

¿Qué hace una dirección de correo electrónico?

Una dirección de correo electrónico se compone de tres partes: la parte local (también conocida como nombre de usuario), el signo @ y la parte del dominio. Cada parte tiene su propia función y está sujeta a su propio conjunto de reglas. A continuación, se ofrece una descripción general rápida.

Según el estándar, la parte local de la dirección de correo electrónico puede tener hasta 64 caracteres y puede estar formada por un conjunto limitado de caracteres. Estos incluyen letras del alfabeto latino en mayúsculas y minúsculas, números del 0 al 9, puntos y caracteres especiales. Los caracteres especiales incluyen `[correo electrónico protegido] # $% ^ & * () _- + = [] {} ~. Está conectado a la parte del dominio con el signo @.

La parte del dominio puede tener hasta 255 caracteres. Puede contener letras del alfabeto latino (tanto en minúsculas como en mayúsculas), números del 0 al 9 y guiones. El guión no puede iniciar ni finalizar la parte del dominio.

También se pueden usar símbolos internacionales, aunque hablaremos de eso más adelante.

¿Se distingue entre mayúsculas y minúsculas?

La respuesta correcta a esta pregunta es sí y no. De acuerdo a RFC 5321 , la parte local de la dirección de correo electrónico distingue entre mayúsculas y minúsculas. Esto significa que, en teoría, [email protected] no es lo mismo que [email protected] Sin embargo, los proveedores de correo electrónico tienen la libertad de tratar las partes locales como sensibles a mayúsculas y minúsculas.

Por ejemplo, [correo electrónico protegido], [correo electrónico protegido] y [correo electrónico protegido] son, en teoría, direcciones de correo electrónico diferentes. Es fácil ver cómo esto podría crear problemas y disminuir la experiencia del usuario si un servidor de correo optara por tratar las partes locales como sensibles a mayúsculas y minúsculas. Por lo tanto, muchos proveedores tratan la parte local de la dirección de correo electrónico como insensible a mayúsculas y minúsculas.

cómo bloquear celdas en hojas de Google

En cuanto a la parte del dominio, RFC 1035 estipula que siempre es insensible a mayúsculas y minúsculas. Esto significa que puede escribirlo en minúsculas, mayúsculas o cualquier combinación de los dos y su correo electrónico terminará en la misma dirección. En la práctica, [email protected], [email protected] y [email protected] son ​​la misma dirección de correo electrónico.

En la práctica

Si bien las direcciones de correo electrónico solo distinguen parcialmente entre mayúsculas y minúsculas, generalmente es seguro pensar en ellas como si no distinguen entre mayúsculas y minúsculas. Todos los proveedores importantes, como Gmail, Yahoo Mail, Hotmail y otros, tratan las partes locales de las direcciones de correo electrónico como insensibles a mayúsculas y minúsculas. Dicho esto, debe verificar las reglas del proveedor de correo electrónico con el que desea crear un correo electrónico.

Vinculado al punto anterior, el RFC 5321 mencionado anteriormente recomienda que las nuevas direcciones de correo electrónico se creen con letras minúsculas solo para evitar posibles confusiones y problemas de entrega.

Por otro lado, si tu amigo o colega tiene una dirección de correo electrónico con una combinación de mayúsculas y minúsculas, es recomendable que la escribas como está cuando les envías un correo electrónico. Si no lo hace, es posible que no se entregue el correo electrónico. Sin embargo, esto no es un problema con los principales proveedores de correo electrónico como Gmail, Yahoo Mail, Hotmail y otros.

Además, Gmail también es insensible a los puntos que se encuentran en la parte local del correo electrónico cuando se trata de la identificación de la cuenta del usuario. Esto significa que si existe la cuenta de [correo electrónico protegido], no podrá registrarse [correo electrónico protegido] o [correo electrónico protegido]

Internacionalización

Originalmente, las direcciones de correo electrónico solo podían registrarse con las letras del alfabeto latino, números y un conjunto limitado de caracteres especiales ASCII. sin embargo, el IETF (Grupo de trabajo de ingeniería de Internet) ha desarrollado posteriormente reglas y estándares para la inclusión de caracteres internacionales.

RFC6530 fue el primero en incluir y regular el uso de caracteres internacionales. RFC6531 ampliado en las reglas y estándares. Posteriormente, se actualizaron las reglas y estándares mediante RFC6532 y RFC6533 .

Ahora puede registrar una dirección de correo electrónico utilizando una amplia gama de alfabetos, caracteres y escrituras. Algunos de los más utilizados incluyen caracteres latinos con diacríticos, alfabeto griego, caracteres chinos tradicionales, caracteres japoneses (hiragana, katakana y kanji), alfabeto cirílico, varias escrituras indias, así como una variedad de otras.

La inclusión y compatibilidad con direcciones de correo electrónico internacionales varía de un proveedor a otro. Incluso algunos de los proveedores más importantes no son totalmente compatibles con direcciones internacionales. Por ejemplo, Google le permite enviar un correo electrónico a una dirección internacional, pero no le permite crear una. Outlook 2016 tiene una funcionalidad similar.

Conclusión

A diferencia de la parte del nombre de dominio, la parte local de una dirección de correo electrónico distingue entre mayúsculas y minúsculas. Dicho esto, muchos proveedores de correo electrónico optan por ignorar la distinción entre mayúsculas y minúsculas de la parte local por razones prácticas y animan a las personas a crear correos electrónicos solo con minúsculas.

Artículos De Interés

La Elección Del Editor

Cómo bloquear o desbloquear a alguien en la aplicación Clubhouse
Cómo bloquear o desbloquear a alguien en la aplicación Clubhouse
Es posible que Clubhouse solo esté en su infancia, pero eso no significa que la plataforma de redes sociales de rápido crecimiento no esté molesta por algunos de los viejos problemas que se encuentran en otras plataformas de redes sociales. Para ser específico, no hay garantías.
Cómo ajustar la calidad del video en Netflix
Cómo ajustar la calidad del video en Netflix
https://www.youtube.com/watch?v=LGLp0UB9d1g Para los fanáticos de las películas, los programas de televisión y los documentales, simplemente no hay reemplazo para Netflix. Originalmente un servicio de alquiler de DVD en línea, Netflix ayudó a marcar el comienzo de la era del entretenimiento en tiempo real. Como la guerra
Revisión de Macromedia Flash Professional 8
Revisión de Macromedia Flash Professional 8
Es difícil creer que Flash nació hace apenas diez años como FutureSplash, un sencillo programa de animación y dibujo vectorial al estilo de los dibujos animados. Desde aquellos primeros días, Macromedia ha incorporado capacidades avanzadas de programación y multimedia para convertir Flash,
Linux Mint 20 BETA está disponible para descargar
Linux Mint 20 BETA está disponible para descargar
Linux Mint ha lanzado una versión preliminar de su próximo lanzamiento 'Ulyana'. Linux Mint 20 ha alcanzado la etapa BETA y viene como un sistema operativo de 64 bits con snapd deshabilitado, confiando en las aplicaciones de repositorio clásicas y flatpak. Los usuarios interesados ​​pueden descargar las ediciones Cinnamon, MATE y Xfce de Linux Mint 20. Cuenta con Cinnamon 4.6, Xfce 4.14,
Cómo ver televisión móvil en tu coche
Cómo ver televisión móvil en tu coche
Desde satélite hasta Slingbox, hay muchas formas de ver televisión en su automóvil. Aquí analizamos las opciones disponibles y el equipo necesario.
Revisión de palmOne Tungsten T5
Revisión de palmOne Tungsten T5
No se deje engañar por el nombre: el T5 no es el sucesor del T3, es más una evolución del exitoso Tungsten E. De hecho, el diseño es casi idéntico. Esto no es nada malo, ya que
Los 10 mejores sitios web gratuitos para aprender idiomas de 2024
Los 10 mejores sitios web gratuitos para aprender idiomas de 2024
Los mejores sitios web gratuitos de aprendizaje de idiomas que te ayudarán a aprender un nuevo idioma o mejorar el actual mediante lecciones, videos y más.